Articles effacés qui apparaissent toujours dans la liste

Imprimer Syndication RSS 2.0

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Bonsoir,

Lorsque j'affiche les fichiers d'un rédacteur (notamment les articles) comment se fait-il que les fichiers effacés soient encore dans la liste ?

http://imageshack.us/photo/my-...2011234558.jpg/
(Tous les fichiers qui apparaissent sur cette capture d'écran ont été effacés).

Merci.

Aller en haut de page Aller en bas de page

Réponses

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonsoir,
es tu passé par le plugin pour faire la suppression de ces fichiers ?
Cordialement.
A+

Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

J'ai refait un essai.

Pour supprimer un article, je le supprime dans Administration des données/articles, puis dans le menu extra correspondant.

Et là tjrs le même problème : le fichier est bien supprimé, mais il est tjrs présent dans la liste des fichiers dans le répertoire du rédacteur (dans admin redacteur).

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

re-,
Citation
Pour supprimer un article, je le supprime dans Administration des données/articles, puis dans le menu extra correspondant.
Et là tjrs le même problème : le fichier est bien supprimé, mais il est tjrs présent dans la liste des fichiers dans le répertoire du rédacteur (dans admin redacteur).
C'est normal car tu ne passes pas par l'administration du plugin pour supprimer les documents donc le plugin ne peut pas savoir ce que tu as supprimé via l'administration de guppy.
Cordialement.
A+

Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Nouvel essai.
Je supprime l'article en commençant dans le plugin admin redacteur puis dans le plugin extra.

Mais tjrs le même problème, il reste présent dans la liste de l'adm redacteur (mais disparaît dans le plugin extra et dans Administration des données/articles).

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

re-,
Citation
Je supprime l'article en commençant dans le plugin admin redacteur puis dans le plugin extra.
Pourquoi as tu besoin de le faire aussi dans le plugin extra étant donné que normalement c'est fait automatiquement lors de la suppression via le plugin adm_redacteur ?
Je vais retester de mon coté pour être sur qu'il n'y a pas un problème.
A+

Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Si je le supprime simplement par l'admin rédacteur, voilà ce que j'obtiens :

http://imageshack.us/photo/my-...2011212845.jpg/


Et dans le menu extra, il est alors tjrs présent dans la liste des articles.



J'ai même essayé en commençant par le supprimer dans le menu extra : mais il faut quand même que je le supprime ensuite dans le menu admin redacteur. Et il reste tjts listé.

http://imageshack.us/photo/my-...2011213851.jpg/
(Tous ces fichiers ont pourtant été supprimés)

Message édité 2 fois, dernière édition par han le Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Bonsoir,

En testant avez-vous rencontré le même problème ?

Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Quand j'ai constaté le bug : Ajoute menu Version 4.6.20 (23/09/2011) - Fork 4.6.24 basé sur GuppY 4.6.16 (LIB 2.3)

Je viens de réessayer avec la mise à jour : Version 4.6.20 (23/09/2011) - Fork 4.6.25 (22/10/2011) basé sur GuppY 4.6.17 (LIB 2.3)

Même problème (Vous n'avez pas ce problème ?) .

D'ailleurs je viens de constater autre chose :

Quand j'écris un article en tant qu'admin, l'éditeur est bien CKeditor
http://imageshack.us/photo/my-images/4/52378671.jpg/

Par contre quand j'écris un article par le menu redacteur c'est FCKeditor...
http://imageshack.us/photo/my-images/402/fckr.jpg/

Pourquoi ?

Message édité 1 fois, dernière édition par han le Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonsoir han,
je ne constate aucun dysfonctionnement après de nombreux essais.
Je vais détailler la manip à faire pour supprimer un article enregistré dans une boite Menu Extra.
1) Tu dois aller dans la zone du plugin adm_redacteur.
2) Ensuite, pour le rédacteur concerné, tu dois cliquer sur l’icône "Afficher tous les fichiers" (icone qui ressemble à un répertoire).
3) Tu cliques sur la croix rouge correspondant à l'article à supprimer.
A+
PS : pour avoir l'éditeur CKEditor, il te faut faire la mise à jour du plugin adm_redacteur disponible en téléchargement à cette adresse.

Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Bonsoir,

Voilà comment je procède.

1) Pour rendre visible l'article :
- Admin redacteur ---->Montrer article (sens interdit---->écran)


2) Pour le supprimer, je fais bien comme tu dis :
- aller dans la zone du plugin adm_redacteur.
- Ensuite, pour le rédacteur concerné, cliquer sur l’icône "Afficher tous les fichiers" (icone qui ressemble à un répertoire).
- Cliquer sur la croix rouge correspondant à l'article à supprimer.

Mais si je m'arrête là, le titre de l'article apparaît toujours dans la boite ajoute-menu, mais l'article n'est plus accessible (la page n'existe pas).
http://imageshack.us/photo/my-...2011000309.jpg/

Donc pour le supprimer définitivement de l'affichage, il faut que je le supprime également dans le menu extra
Mais par contre quand je clique sur l’icône "Afficher tous les fichiers" (icone qui ressemble à un répertoire) dans l'admin redacteur, il est toujours affiché.
http://imageshack.us/photo/my-...2011000907.jpg/

...??????


Serait-ce un conflit avec le plugin "Menu extra" ?
Dois-je aussi voir avec son concepteur (JeanMi) ?

Message édité 1 fois, dernière édition par han le Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonjour han,
Citation
Mais par contre quand je clique sur l’icône "Afficher tous les fichiers" (icone qui ressemble à un répertoire) dans l'admin redacteur, il est toujours affiché.

Lorsque tu supprimes l'article, l'item du Menu Extra correspondant devrait être également supprimé ce qui n'est pas le cas pour toi et c'est ce qui provoque tous les autres problèmes. De mon coté, je ne constate pas ce dysfonctionnement.
Maintenant, il faut que tu saches que si tu passes par le plugin ajoutemenu pour supprimer un item de Menu Extra, il est normal que la suppression ne soit pas répercutée dans le plugin adm_redacteur.
Je ne pense pas que le plugin de jeanmi soit en cause.
Je vais refaire des tests du coté de la suppression dans les boites Menu Extra.
Je te tiens au courant quand j'ai trouvé une piste.
Cordialement.
A+

Message édité 1 fois, dernière édition par jchouix le Aller en haut de page Aller en bas de page

han

Actif
Actif

Avatar de han

Messages : 179

Inscription :

Bonjour

Citation
Maintenant, il faut que tu saches que si tu passes par le plugin ajoutemenu pour supprimer un item de Menu Extra, il est normal que la suppression ne soit pas répercutée dans le plugin adm_redacteur.
Je ne pense pas que le plugin de jeanmi soit en cause.


En fait si je passe également par le plugin ajoutemenu pour supprimer un item, c'est parce que la suppression par le menu admin redacteur n'est pas complète.
http://imageshack.us/photo/my-...2011000309.jpg/

Veux-tu que je t'envoie les fichiers de ma version locale du site pour faire des essais ?

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonsoir han,
Citation
En fait si je passe également par le plugin ajoutemenu pour supprimer un item, c'est parce que la suppression par le menu admin redacteur n'est pas complète.
J'ai bien compris mais j'ai refais des essais et je n'arrive pas à reproduire ton problème. Tout fonctionne correctement de mon coté en ce qui concerne la suppression des articles (affectés ou non à un Menu Extra).
Pour savoir si ça vient de ton installation, je te conseille de repartir en local avec un version guppy 4.6.17 fraichement téléchargée et ensuite, tu installes les dernières versions des plugins adm_redacteur et ajoutemenu et tu refais des tests. Il n'y a aucune raison que ça marche pour tous les autres guppystes et pas pour toi.
Cordialement.
A+

Aller en haut de page Aller en bas de page