Codage des menus (accents)

Imprimer Syndication RSS 2.0

Cesar

Nouveau
Nouveau

Avatar de Cesar

Messages : 6

Inscription :

J'ai mis en place récemment le "plugin" GetFileHtml
cela fonctionne
les pages html s'affichent bien
mais tous mes menus s'affichent avec des codes bizarres

comme : T�l�chargement

quand je clique sur un autre menu tout redevient normal
comment paramétrer pour éviter ce problème d'affichage

César

Aller en haut de page Aller en bas de page

Réponses

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonsoir,
c'est un problème de codage des caractères par rapport au charset de la page.
As tu une adresse pour voir ?
Merci.

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonsoir,
je viens d'aller voir et c'est bien un problème d'encodage des caractères de ta page.
Avec quel éditeur as tu créé ta page html ?
Vérifies que le codage de ta page est bien iso-8859-1 (europe de l'ouest) et pas utf-8 comme c'est le cas actuellement.
A+

Aller en haut de page Aller en bas de page

Cesar

Nouveau
Nouveau

Avatar de Cesar

Messages : 6

Inscription :

Je ne comprends pas je n'ai mis que 3 pages html
accessibles avec le menu du haut (Pages)

et quand j'affiche le code source il y a bien pour les 3 la ligne :

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

je les ai écrites avec Dreamweaver CS3

merci pour ta réponse

M.A.R.

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonsoir,
Citation
je les ai écrites avec Dreamweaver CS3

Tu ouvres ta page dans Dreamweaver CS3 et tu vas dans le menu "modifier" puis "propriétés de la page". Ensuite, tu sélectionnes dans la fenetre l'item "Titre/codage" à gauche et ensuite, à droite, dans le champ déroulant intitulé "codage" tu sélectionnes l'option "Europe centrale (ISO)".
Tu appliques les modifs et enfin, tu enregistres ta page.
Le codage de ta page correspondra ainsi à l'encodage iso de guppy et n'induira pas en erreur le navigateur pour son affichage.
A+

Aller en haut de page Aller en bas de page

Cesar

Nouveau
Nouveau

Avatar de Cesar

Messages : 6

Inscription :

bonsoir,

j'ai changé le codage des 3 pages (europe centrale iso = <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />)

hélas aucun changements...

dès que je charge ces pages les accents s'affichent avec des caractères bizarres


dès que je reviens à l'accueil cela redevient normal

je ne comprends pas ...

merci

MAR

Aller en haut de page Aller en bas de page

Cesar

Nouveau
Nouveau

Avatar de Cesar

Messages : 6

Inscription :

pour compléter mon message précédent
Citation
bonsoir,
j'ai changé le codage des 3 pages (europe centrale iso = <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2"/>)
hélas aucun changements...
dès que je charge ces pages les accents s'affichent avec des caractères bizarres
dès que je reviens à l'accueil cela redevient normal
je ne comprends pas ...
merci
MAR

quand je demande l'affichage du code source de ma page d'accueil
il y a le code :
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
et non
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />

où cela se règle-t-il dans guppy ?

merci MAR

Message édité 1 fois, dernière édition par jchouix le Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

bonjour Cesar,
je pense que tu n'as pas compris ce que je te demandais de faire.
Tu as modifié la déclaration du charset de ta page mais tu n'as pas changé l'encodage de ta page d'où le fait que le problème est toujours présent.
Dis autrement, ce n'est pas parce que tu mets <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2"/> dans l'entête de ta page que tes caractères sont encodés en iso-8859-2.
Le problème concernant tes fichiers,c'est qu'ils sont encodés en UTF-8 (enfin, je pense) ce qui n'est pas bon car il faut qu'ils soit encodés en iso-8859-1.
J'espère avoir été plus clair cette fois.
A+

Aller en haut de page Aller en bas de page

Cesar

Nouveau
Nouveau

Avatar de Cesar

Messages : 6

Inscription :

Non j'avais bien compris et dans Dreamweaver (en fait j'ai Dreamweaver 8 et pas CS3 mais cela ne doit rien changer)
j'ai bien fait modifier" puis propriétés de la page et Titre/codage et dans le champ déroulant intitulé codage j'ai sélectionné Europe centrale (ISO)

Mais hélas cela n'a rien changé... (est-ce que le Titre/Codage joue un rôle : XHTML 1.0 strict ou HTML 4.01 strict ... ?

j'avais simplement été voir le résultat dans le code

merci si tu as une idée

César

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1370

Inscription :

re-,
peux tu m'envoyer par mail tes fichiers html pour que je jette un coup d'oeil.
Merci
A+

Aller en haut de page Aller en bas de page