Version haut débit de: Forum du site Lebrikabrak
Aide - Rechercher - Membres

Impossible de supprimer un groupe de rédacteurs

han (24 Octobre 2016, 14:57)
Bonjour Jchouix,
Lorsque j'essaie de supprimer un groupe de rédacteur, voilà le message que j'obtiens :

Fatal error: Call to undefined method Writer_filehtml_model::delete_files_by_id() in /var/www/legtux.org/users/ecoleblaisybas/www/essai503/plugins/adm_redacteurs/helpers/manage_groups_helper.php on line 387

(j'ai installé la version 6.9 du plugin).

Cordialement.
Han

Edit :
J'ai également un souci pour créer un groupe si le nom contient des majuscules : est-ce normal ?

Edit2:
J'ai essayé de modifier un article avec l'un des rédacteurs crées : la modification semble se faire mais il est ensuite impossible d'accéder à l'article. A noter que cet article utilise Tabberguppy.
jchouix (24 Octobre 2016, 22:50)
Bonsoir han,
je vais étudier les problèmes que tu soulèves et je te tiens au courant.
Cordialement.
jchouix (24 Octobre 2016, 23:24)
Re-,
concernant le problème avec les majuscules dans le nom du groupe ou du rédacteur, c'est de ma faute car j'ai oublié de prendre en compte les lettres majuscules ainsi que les tirets dans la version 6.9 du plugin. Pour corriger, il te faut éditer le fichier var_helper.php situé dans le répertoire plugins/adm_redacteurs/helpers/
Ensuite, tu vas à la ligne 795 où tu as ce code :
return preg_match('`[^a-z0-9]+`', $name) ? FALSE : TRUE;

Tu écris à la place :
return preg_match('`[^-a-z0-9_]+`i', $name) ? FALSE : TRUE;


Tu vas ensuite à la ligne 809 où tu as ce code :
return preg_match('`[^a-z0-9]+`', $name) ? FALSE : TRUE;

Tu écris à la place :
return preg_match('`[^-a-z0-9_]+`i', $name) ? FALSE : TRUE;

Cordialement.
jchouix (24 Octobre 2016, 23:30)
Re-,
concernant le problème avec l'accès à l'article après sa modification, as tu vérifié que le rédacteur avait le droit d'activer ou désactiver l'article dans sa config ? Je te demande ça car s'il n'a pas ce droit alors à chaque fois qu'il modifiera l'article, celui-ci passera en status inactif automatiquement et deviendra donc inaccessible. C'est une nouveauté introduite dans la version 6.9 du plugin ce qui permet le contrôle de ce qui est écrit par les rédacteurs.
Cordialement.
jchouix (24 Octobre 2016, 23:32)
Bonjour han,
concernant le problème lors de la suppression du groupe, je te propose d'installer le patch correctif que je te mets en pièce jointe. Normalement, c'est ok mais reviens me le confirmer s'il te plait.
Cordialement.
Fichier joint
Télécharger
Fichier téléchargé 348 fois (nom du fichier: patch_correctif_suppression_groupes_pour_adm_redacteurs_v6.9.zip ; taille: 9.783 KO, date d'upload: 25 Octobre 2016, 13:51)
ce patch permet de corriger un couic lors de la suppression d'un groupe avec tous ses rédacteurs pour adm_redacteurs v6.9
han (25 Octobre 2016, 17:58)
Bonjour Jchouix,

1) Je viens de tester ton patch : la suppression des groupes se fait correctement.

2) Le problème des majuscules est aussi résolu.

3) Concernant l'article disparu, effectivement il fallait que le rédacteur ait le droit d'activer ou désactiver l'article dans sa config. Par contre, j'ai un petit souci :
voici comment était l'article (que j'ai écrit en tant qu'admin) avant que le rédacteur l'édite : avant
Et voici comment il est après l'édition du rédacteur (toutes les boites à gauche et tout est souligné) : après.

Han
jchouix (25 Octobre 2016, 19:52)
Bonsoir han,
merci pour ton retour de test. Concernant le soucis avec l'affichage de l'article, cela apparait uniquement avec l'utilisation de Tabberguppy ou bien sur tous les articles ?
Cordialement
han (25 Octobre 2016, 22:39)
Bonsoir Jchouix,

Le problème était apparu avec un rédacteur avant que j'applique tes divers corrections.
Je viens de refaire un essai avec un article simple et un article Tabberguppy et le problème n'est pas réapparu.

C'est donc tout bon.
Merci et bonne nuit.
han (05 Novembre 2016, 23:17)
Bonsoir Jchouix,
J'ai parlé trop vite : le problème est réapparu.

Je t'ai envoyé un "petit mail"...

Han