Version haut débit de: Forum du site Lebrikabrak
Aide - Rechercher - Membres

Migration: Fatal error

cyprin (23 Décembre 2014, 22:26)
Bonjour,
Lorsque j'essaye d'effectuer la migration du plugin adm_redacteurs, j'obtiens ce message d'erreur:
Citation
Fatal error: Uncaught exception 'Exception' with message 'Session must to be active' in /home/www/html/college/val-des-usses.frangy/plugins/adm_redacteurs/helpers/security_helper.php:43 Stack trace: #0 /home/www/html/college/val-des-usses.frangy/admin/plugins/adm_redacteurs/controllers/migrate_data_controller.php(101): Security_helper::create_token('ADMR_migrate_da...') #1 /home/www/html/college/val-des-usses.frangy/admin/plugins/adm_redacteurs/controllers/migrate_data_controller.php(59): Migrate_data->migrate() #2 [internal function]: Migrate_data->index() #3 /home/www/html/college/val-des-usses.frangy/admin/plugins/adm_redacteurs/admin.inc(39): call_user_func_array(Array, Array) #4 /home/www/html/college/val-des-usses.frangy/admin/admin.php(191): include('/home/www/html/...') #5 {main} thrown in /home/www/html/college/val-des-usses.frangy/plugins/adm_redacteurs/helpers/security_helper.php on line 43

Ai-je fait une mauvaise manip?
Merci
jchouix (23 Décembre 2014, 23:19)
Bonsoir,
à priori, tu as un problème de session qui n'est pas active sur ton hébergement. Peux tu te connecter en tant que rédacteur sans problème ?
Cordialement.
mistinguette (23 Décembre 2014, 23:28)
Bonjour,
Je suis en train de tester en local. J'ai récupérer mes rédacteurs, mais pas les groupes...mais bon, ça date d'y a 2 min, faut que j'approfondisse. Pas de fatal error pour moi
jchouix (24 Décembre 2014, 0:00)
Bonsoir mistinguette,
Citation (mistinguette)
J'ai récupérer mes rédacteurs, mais pas les groupes...

Normalement, tu as du récupérer les groupes. Par contre, il est vrai que l'affectation des rédacteurs dans les groupes est à refaire. Pour réaliser cela facilement, tu cliques sur l'icone "Gérer les groupes rédacteurs" et ensuite, en face de chaque groupe, dans la colonne du tableau intitulée "commandes", tu as une icône intitulée "Affecter des rédacteurs au groupe". Tu cliques dessus et tu pourras ensuite sélectionner dans la liste tous les rédacteurs que tu souhaites affecter au groupe ( cliquer sur les rédacteurs souhaités en maintenant la touche ctrl appuyée).
Cordialement.
mistinguette (24 Décembre 2014, 0:10)
Normalement, tu as du récupérer les groupes

Bonsoir Jchouix
Ben désolé, mais ça pas marché.... Je l'ai fais 2 fois, mais la procédure semble bien se dérouler ( sur toutes les étapes), j'ai bien tous mes rédacteurs mais pas les groupes : dans gérer les groupes, il n'y a rien.
cordialement
jchouix (24 Décembre 2014, 0:26)
Bonsoir mistinguette,
je crois avoir trouvé le couic. Tu édites le fichier intitulé "group_model.php" situé dans le répertoire plugins/adm_redacteurs/models/ et tu vas à la ligne 339 où tu as ce code :
if (empty($writers)) {

tu écris à la place :
if (empty($groups)) {

Dis moi si c'est ok.
Cordialement.
mistinguette (24 Décembre 2014, 0:42)
ça marche! j'ai retrouvé tous mes groupes. Merci bien ;-)
Bon maintenant dodo !
Cordialement
Mistinguette
jchouix (24 Décembre 2014, 1:08)
Re-,
merci pour ton retour. J'ai sorti une version RC3 du plugin qui intègre cette correction.
Cordialement.
cyprin (25 Décembre 2014, 11:29)
Bonsoir,
à priori, tu as un problème de session qui n'est pas active sur ton hébergement. Peux tu te connecter en tant que rédacteur sans problème ?
Cordialement.

J'ai crée un rédacteur que j'ai connecter et tout fonctionne.
jchouix (25 Décembre 2014, 19:44)
Bonsoir,
étant donné que la migration n'est à faire qu'une seule fois, je te conseille de la faire en local avec un serveur type wamp. Ensuite, tu n'auras qu'à rapatrier tout le contenu du répertoire data/plugins/adm_redacteurs/ sur ton hébergement via ftp.
Cordialement.
cyprin (25 Décembre 2014, 20:07)
J'ai aussi un problème avec openfiches pour un site perso donc je suis en local avec easyphp depuis ce matin : je deviens fou :)
Quand je veux modifier un paramètre dans congif generale de openfiches , cela me crée un décalage dans l'affichage des fiches :(
Dans la gestion des fiches elles ont disparu mais pas dans data...

Aucun problème pour migrer de guppy 4.6 à 5.0 mais les plugins c'est autre chose.
Depuis 4 ou 5 ans que j'utilise guppy ( 3 sites ) je n'avais jamais eu de problèmes: faut un début à tout :)

Demain, j'essayerai avec adm_redacteurs ;) en local

Merci pour ton aide

PS: suis-je le seul à rencontrer des problèmes de migration avec les plugins?

linuxmr (27 Décembre 2014, 16:52)
Bonjour,

La réponse que je peux donner est la suivante.

Les catégories enregistrées au niveau de la config générale démarrent à la catégorie No 2, ensuite catégorie 4 etc..

Pourquoi cette façon de faire?

L'ordre convenable aurait été de renseigner les catégories de 1 à 18
Suite à la migration, les catégories sont renseignées dans les fichiers listcat.inc et listmod.inc n'ont plus d'enregistrement à espaces donc avec des catégories vides.

Il est important de noter que toute catégorie non précisée fait que le programme considère que la catégorie est à supprimer.
Exemple:
Si le nom de la catégorie est changé, ceci fait que toutes les fiches rattachées à une ancienne catégorie seront rattachées à cette nouvelle catégorie
Si le nombre de caractères est réduit à 0, il y a une suppression de la catégorie et de toutes les fiches attachées à cette catégorie.

Ceci explique les suppressions des fiches.
la solution est de remettre les catégories dans l'ordre de 1 à 18, pas de décalage à la suite de la migration, faire ensuite l'enregistrement de la config générale.

je viens de faire le test, les fiches ne sont pas perdues.
A+
cyprin (29 Décembre 2014, 12:50)
Bonjour,
Merci linuxmr pour ton aide, je continue le pb rencontré avec openfiches sur le forum approprié : http://www.randosnormandie.inf...at=06&fid=1

jchouix : ayant passé dèjà pas mal de temps sur openfiches, j'abandonne avec adm_redacteurs.
Je ne fais pas de migration: j'installe la nouvelle version.
En fait, cela me permettra de faire du ménage puisque je n'ai que 2 rédacteurs actifs que je vais recréer puis je leur attribuerai leur articles respectifs.

Merci à tous les deux.
jchouix (29 Décembre 2014, 12:59)
Bonjour cyprin,
étant donné que tu as seulement deux rédacteurs, tu as raison de dire que ce sera plus vite fait de les recréer en leur réaffectant leurs articles respectifs.
Bonne continuation.
Cordialement.
linuxmr (29 Décembre 2014, 21:44)
Bonsoir,

La réponse a été faite sur mon site.

Un coucou en passant à Jerome.

Je te souhaite une bonne année 2015 et tous mes voeux de réussite

A+
jchouix (29 Décembre 2014, 22:45)
Bonsoir michel,
merci pour tes voeux, je vais en avoir bien besoin car ce n'est pas gagné vu les derniers couics découverts par fred.
A mon tour, je te souhaite mes meilleurs voeux pour la nouvelle année qui va vite arriver.
Amicalement.