Insertion images forum 4.6

Imprimer Syndication RSS 2.0

jchouix

Administrateur

Avatar de jchouix

Messages : 1382

Inscription :

bonsoir,
je viens de faire des tests et ils sont négatifs que ce soit du coté wysiwyg ou non donc ce que tu demandes n'est pas possible actuellement.
Désolé.

Tu as de la chance car je viens de trouver une solution simple qui va te permettre de faire ce que tu veux.
Alors tu vas éditer le fichier initulé pgeditor.php situé dans le répertoire inc/pgeditor/ et tu vas à la ligne 899 où tu as ce code :
$matches[0] = '[a href="'.$matches[1].'" target="_blank"]'.wordwrap($matches[2],50," ",1).'[/a]'; // Target Blank
Tu écris à la place :
$matches[0] = '[a href="'.$matches[1].'" target="_blank"]'.wordwrap($matches[2],500," ",1).'[/a]'; // Target Blank


Ensuite, tu vas à la ligne 911 où tu as ce code :
$matches[0] = '[a href="'.$matches[1].'" target="_blank"]'.wordwrap($matches[2],50," ",1).'[/a]'; // Target Blank

tu écris à la place :
$matches[0] = '[a href="'.$matches[1].'" target="_blank"]'.wordwrap($matches[2],500," ",1).'[/a]'; // Target Blank


Enfin, tu vas à la ligne 918 où tu as ce code :
$matches[0] = '[a href="'.$matches[2].'" target="_blank"]'.wordwrap($matches[2],50," ",1).'[/a]'; // Target Blank

et tu écris :
$matches[0] = '[a href="'.$matches[2].'" target="_blank"]'.wordwrap($matches[2],500," ",1).'[/a]'; // Target Blank


Je t'ai surligné en jaune la modification à apporter.

Le mode d'emploi est simple :
En mode wysiwyg, tu insères ta miniature en cliquant sur l'icone image et ensuite, tu sélectionnes ton image en cliquant dessus et tu insères le lien vers ton image non miniature en cliquant sur l'icone lien.
En mode non wysiwyg, c'est le même principe.
A+

Message édité 1 fois, dernière édition par jchouix le Aller en haut de page Aller en bas de page

spad64

Nouveau
Nouveau

Avatar de spad64

Messages : 16

Inscription :

Bonsoir Jchouix,
J'ai modifié le code suivant tes indications.
Je n'ai pas réussi à passer l'éditeur en mode non wysiwyg.
L'idéal pour les miniatures cliquable ce sont les balises IMG, il suffit alors de récupérer le code chez l'hebergeur d'image.
Merci, je suis trés content que mes membres puissent maintenant poster des photos dans le forum.
Dom

Aller en haut de page Aller en bas de page

jac83

Nouveau
Nouveau

Avatar de jac83

Messages : 2

Inscription :

bonjour jchouix :fsb2_oui:
je réveille un peu cette discussion car j'ai un petit souci avec l'insertion d'image dans le forum.
jusqu'a il y a 3 jours cela fonctionnait correctement (merci encore ... car c'est sur ton site que j'avais pris la manip) mais tout d'un coup plus rien si ce n'est le message suivant:[function.getimagesize]: failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden in /mnt/101/sda/3/f/vttplus/inc/pgeditor/pgeditor.php on line 819
j'ai donc remis des fichiers de sauvegarde ... idem ??? :fsb2_red: ... puis des fichiers pris sur un site ou ça fonctionne ...idem ???
mon recadrage des images est réglé a 400 px de large, je suis en guppy4.6.11 et mis a part le plugin contact (a priori sans incidences), je n'ai rien installé depuis quelques jours .
les messages texte passent correctement, il y a blocage complet avec les images = message d'erreur + blocage sur postguest.php
voilà j'espère avoir été clair ...
a+ cordialement jacques
le site en question : http://vttplus.free.fr

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1382

Inscription :

bonsoir,
tu devrais contacter l'hébergeur car cela semble provenir d'un réglage de sécurité sur le serveur.
Tiens moi au courant quand tu auras sa réponse.
A+

Aller en haut de page Aller en bas de page

jac83

Nouveau
Nouveau

Avatar de jac83

Messages : 2

Inscription :

bonsoir,
merci pour l'info, ça me rassure un peu ... mais l'hébergeur étant free, je ne suis pas sur de pouvoir obtenir un changement ... ??? c'est peut être l'occasion pour moi de passer a un hébergeur payant ...
cordialement jacques (je poste si j'obtiens des infos)

Aller en haut de page Aller en bas de page

Katryne

Actif
Actif

Avatar de Katryne

Messages : 195

Inscription :

Bonjour Jérôme,

Pour mieux faire fonctionner l'insertion d'image sur les forums et le blog (Merci Icare pour le diagnostic)
Les hébergeurs d'image donnent un lien traficoté vers un fichier php (en général) qui, lui, affiche l'image.
Il faut donc trouver la vraie adresse de l'image.
  • appeler le lien donné par le site d'hébergement d'image
  • quand l'image s'affiche, cliquer sur l'image et choisir dans le menu contextuel Afficher l'image (ou équivalent selon les navigateurs)
  • dans la nouvelle page qui s'ouvre alors, avec l'image, récupérer la VRAIE url dans la barre d'adresse et elle fonctionnera pour l'icône d'insertion d'image de pgeditor

Les hébergeurs d'images utilisent presque tous un script visualisateur d'images (wiewer) pour contourner le problème allow_url. Mais comme ce script est différent et avec des noms différents d'un hébergeur à l'autre, cela semble difficile de modifier en ce sens la fonction d'insertion d'image de PGEditor.

PS : sous Firefox beta 29, le champ d'édition de Pgeditor ne s'affiche pas, mais uniquement sur ton site. Sur les autres Guppy, ça marche.

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1382

Inscription :

Bonjour katryne,
merci pour ces infos.
Cordialement
PS : je vais m'occuper de corriger le problème que tu me signales

Aller en haut de page Aller en bas de page