Citation de code illisible sous IE

Imprimer Syndication RSS 2.0

Katryne

Actif
Actif

Avatar de Katryne

Messages : 195

Inscription :

Bonsoir Jérôme !
Depuis la 4.6.14, je rencontre des problèmes pour la citation de code dans le forum sous Internet explorer. Le conteneur avec sa barre de défilement est doublé et cache le texte contenu.
Voilà un exemple, sur mon forum de GuppyStory où je collecte les astuces pour Guppy et les classe par thème:http://guppystory.org/plugins/...fid=1&cat=9

C6forum n'a pas évolué récemment, Icare lui fait utiliser PgEditor depuis l'an passé.

Sur ma demande, tu m'avais expliqué 2 forkages l'an passé pour que le code colorisé de Pgeditor et son conteneur s'affichent correctement aussi en page d'accueil dans la citation des derniers billets du blog. Mais si le site est resté forké ainsi, c'est une application dont je ne me sers plus.

Voilà ce que donne mon post que je n'ai saisi qu'avec PGeditor, quand j'en regarde la source en admin:

<div class="code"><span class="code">Code : php</span>
<pre><code>//$display .= smileyPGEditor($nameForm, $namePGEditor, $width);</code></pre>
</div>


Le formatage "code" semble être appliqué 2 fois.
Pourtant je suis bien certaine de n'avoir copié que que les lignes provenant du fichier, sans formatage (nettoyé avec PureText avant de coller ce que j'avais copié)

D'où cela peut-il venir ?

Merci de ton expertise.
Katryne

Aller en haut de page Aller en bas de page

Réponses

jchouix

Administrateur

Avatar de jchouix

Messages : 1382

Inscription :

bonsoir Katryne,
le code source html que tu me montres est correct donc le problème vient de la mauvaise interprétation CSS par internet explorer.
Il te faut aller bidouiller dans la feuille de style de l'éditeur pour ie qui se trouve à cette adresse inc/config_pgeditor_guppy/style/pgeditor-ie.css.
A+

Aller en haut de page Aller en bas de page

Katryne

Actif
Actif

Avatar de Katryne

Messages : 195

Inscription :

Coucou Jérôme ! Désolée du retard à l'allumage. Merci de ton aide. Je ne t'ai pas répondu parce que je n'ai toujours pas trouvé la cause de l'anomalie. Une petite modification du CSS a amélioré la chose, surtout quand on utilise IE en mode compatibilité, mais ce n'est pas encore guéri. Si je trouve, je te dis.

Aller en haut de page Aller en bas de page

jchouix

Administrateur

Avatar de jchouix

Messages : 1382

Inscription :

bonjour katryne,
as tu recherché du coté des instructions CSS "overflow-x" et "overflow-y" qui sont made in IE ?
A+

Aller en haut de page Aller en bas de page